PCSHM (Playseats, cockpits et simulateurs home-made) Index du Forum PCSHM (Playseats, cockpits et simulateurs home-made)
Discussions à propos des cockpits et simulateurs faits maison, dédiés aux jeux de courses automobiles.
 
 FAQFAQ   RechercherRechercher   MembresMembres   GroupesGroupes   S’enregistrerS’enregistrer 
 ProfilProfil   Se connecter pour vérifier ses messages privésSe connecter pour vérifier ses messages privés   ConnexionConnexion 

Aide mon moteur ne se lance pas

 
Poster un nouveau sujet   Répondre au sujet    PCSHM (Playseats, cockpits et simulateurs home-made) Index du Forum -> Les tutoriels -> Questions
Sujet précédent :: Sujet suivant  
Auteur Message
laurent34400
Occasionnel
Occasionnel

Hors ligne

Inscrit le: 08 Oct 2018
Messages: 27
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: France
Régions (France): Languedoc-Roussillon
Département (France): 34- Hérault
Ville: lunel
04/07/1985 Masculin
Point(s): 135
Moyenne de points: 5,00

MessagePosté le: Jeu 18 Oct - 09:23 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant


salut tout le monde hier j'ai reçu mes fils du coup j'ai câblé une carte arduino et une motomonster avec un moteur pour voir si ça fonctionné mais rien ne fonctionne j'ai tout revérifié mais je ne voit pas le bug .


je compte tourné avec 2 carte arduino , 2 carte motomonster , 2 moteur d'essuie glace .
J'ai quelqu'un du forum qui m'avais fournie le code pour l'arduino jusque la top j'ai juste rajouté le a a la fin du code car j'ai la version d'essai de simtools la 2.3 .
je les transféré dans la carte sans soucis .


Mais la le moteur ne bouge pas d'un poils j'ai essayé de changé de potentiomètre mais rien n'y fait ...


Si quelqu'un a une idée je suis preneur je débute donc désolé .


Merci d'avance 









Revenir en haut
Publicité






MessagePosté le: Jeu 18 Oct - 09:23 (2018)    Sujet du message: Publicité

PublicitéSupprimer les publicités ?
Revenir en haut
Wanegain
Administrateur
Administrateur

Hors ligne

Inscrit le: 08 Mai 2012
Messages: 15 854
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: Belgique
Régions (France): Autre
Département (France): Autre
Ville: Bruxelles
17/04/1982 Masculin Bélier (21mar-19avr)
Point(s): 157 766
Moyenne de points: 9,95

MessagePosté le: Jeu 18 Oct - 09:49 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant

Salut,

Peux-tu donner le schéma de câblage ?
As-tu configuré le profil par défaut dans Axis Assignment ?

Ensuite il faut retirer le "- End" dans le stop il ne doit y avoir que XE00C
_________________
Profils Converter et Codes Arduino
Tuto : simulateur pour moins de 450€
KIT pour créer son simulateur 2DOF


Revenir en haut
laurent34400
Occasionnel
Occasionnel

Hors ligne

Inscrit le: 08 Oct 2018
Messages: 27
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: France
Régions (France): Languedoc-Roussillon
Département (France): 34- Hérault
Ville: lunel
04/07/1985 Masculin
Point(s): 135
Moyenne de points: 5,00

MessagePosté le: Jeu 18 Oct - 09:56 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant

salut voici ce que j ai envoyé dans l arduino  :




/*
  1.24 = improve function with the power command
  
  10 bits (16 bits value / 64)
  
  Com Speed : 115200 bauds
  
  XL<Axis1a>CXR<Axis2a>C
  XE00C - End


  Pin map
  _INA1 = 2;
  _INB1 = 4;
  _EN1DIAG1 = 6; (inutile)


  _INA2 = 7;
  _INB2 = 8;
  _EN2DIAG2 = 12; (inutile)




Analog Pins
  Pin 9  - pwm motor 1
  Pin 10 - pwm motor 2


Pin A0 - input of feedback positioning from motor 1
Pin A1 - input of feedback positioning from motor 2
  
As well 5v and GND pins tapped in to feed feedback pots too.
*/


#include <DualVNH5019MotorShield.h>
//md.setM1Speed(i); -400 to 400
//md.setM2Speed(i); -400 to 400
DualVNH5019MotorShield md;


//Some speed test switches for testers Wink
#define FASTADC  1 //Hack to speed up the arduino analogue read function, comment out with // to disable this hack


// defines for setting and clearing register bits
#ifndef cbi
#define cbi(sfr, bit) (_SFR_BYTE(sfr) &= ~_BV(bit))
#endif
#ifndef sbi
#define sbi(sfr, bit) (_SFR_BYTE(sfr) |= _BV(bit))
#endif


#define LOWBYTE(v)   ((unsigned char) (v)) //Read
#define HIGHBYTE(v)  ((unsigned char) (((unsigned int) (v)) >> 8))
#define BYTELOW(v)   (*(((unsigned char *) (&v) + 1))) //Write
#define BYTEHIGH(v)  (*((unsigned char *) (&v)))


int DeadZone   = 5; //increase this value to reduce vibrations of motors
int ReadAnalog = 6;


int currentanalogue1 = 0;
int currentanalogue2 = 0;


int target1 = 512;
int target2 = 512;


int buffer           = 0;
int buffercount      = -1;
int commandbuffer[5] = {0};


// Pot feedback inputs
int FeedbackPin1  = A0; // select the input pin for the potentiometer 1
int FeedbackPin2 = A1; // select the input pin for the potentiometer 2


//180°


int FeedbackMax1 = 962;
int FeedbackMin1 = 62;
int FeedbackMax2 = 962;
int FeedbackMin2 = 62;


//150°
/*
int FeedbackMax = 888;
int FeedbackMin = 136;
*/


int FeedbackPotDeadZone1 = 0; // +/- of this value will not move the motor
int FeedbackPotDeadZone2 = 0; // +/- of this value will not move the motor


//PID variables


double K_motor_1 = 1;
double proportional1 = 4.200; //initial value
double integral1 = 0.400;
double derivative1 = 0.400;
double K_motor_2 = 1;
double proportional2 = 4.200;
double integral2 = 0.400;
double derivative2 = 0.400;


int OutputM1  = 0;
int OutputM2 = 0;


double integrated_motor_1_error = 0;
double integrated_motor_2_error = 0;
float last_motor_1_error     = 0;
float last_motor_2_error     = 0; 


int disable = 1; //Motor stop flag


//Variables pour la liaison serie de la sabertooth
int PowerM1 = 0;              //puissance moteur 1 [-127 127]
int PowerM2 = 0;              //puissance moteur 2 [-127 127]


void setup()
{
  Serial.begin(115200);


  md.init();


  md.setM1Speed(0);
  md.setM2Speed(0);

disable = 1;


  #if FASTADC
// set analogue prescale to 16
sbi(ADCSRA,ADPS2) ;
cbi(ADCSRA,ADPS1) ;
cbi(ADCSRA,ADPS0) ;
  #endif
  


}


void FeedbackPotWorker()
{
  currentanalogue1 = 0;
  currentanalogue2 = 0;
      
  for(int z=0;z<ReadAnalog;z++)
  {
    currentanalogue1 += analogRead(FeedbackPin1);
  currentanalogue2 += analogRead(FeedbackPin2);
    }


  currentanalogue1 /= ReadAnalog;
  currentanalogue2 /= ReadAnalog;
}


void SerialWorker()
{
while(Serial.available()) 
{
if(buffercount==-1)
{
buffer = Serial.read();
if(buffer != 'X'){buffercount=-1;}else{buffercount=0;}
}
else
{
buffer = Serial.read();
commandbuffer[buffercount]=buffer;
buffercount++;
if(buffercount > 3)
{
if(commandbuffer[3]=='C'){ParseCommand();}
buffercount=-1;
}
}
}
}


void ParseCommand()
{
if(commandbuffer[0]=='L') //Set motor 1 position to High and Low value 0 to 1023
{
target1=(commandbuffer[1]*256)+commandbuffer[2];
    target1=map(target1,0,1023,FeedbackMin1,FeedbackMax1);
disable=0;
return;
}
if(commandbuffer[0]=='R') //Set motor 2 position to High and Low value 0 to 1023
{
target2=(commandbuffer[1]*256)+commandbuffer[2];
    target2=map(target2,0,1023,FeedbackMin2,FeedbackMax2);
disable=0;
return;
}
if(commandbuffer[0]=='E') //Disable power on both motor
{
    unsigned long start;
    unsigned long time;
    start=millis();
    
    target1=512;
    target2=512;
    
    time = millis();
    
    while(time < (start + 2000)) //2s
    {
      FeedbackPotWorker();
      CalculatePID();
      SetPower();
      time=millis();
    }


    md.setM1Speed(0);
    md.setM2Speed(0);
       
    disable=1;
    return;
  }
}


int updateMotor1Pid(int targetPosition, int currentPosition)   
{
float error = (float)targetPosition - (float)currentPosition; 
float pTerm_motor = proportional1 * error;
integrated_motor_1_error += error;                                       
float iTerm_motor = integral1 * constrain(integrated_motor_1_error, -100, 100);
float dTerm_motor = derivative1 * (error - last_motor_1_error);                            
last_motor_1_error = error;
return constrain(K_motor_1*(pTerm_motor + iTerm_motor + dTerm_motor), -255, 255);
}


int updateMotor2Pid(int targetPosition, int currentPosition)   
{
float error = (float)targetPosition - (float)currentPosition; 
float pTerm_motor = proportional2 * error;
integrated_motor_2_error += error;                                       
float iTerm_motor = integral2 * constrain(integrated_motor_2_error, -100, 100);
float dTerm_motor = derivative2 * (error - last_motor_2_error);                            
last_motor_2_error = error;


return constrain(K_motor_2*(pTerm_motor + iTerm_motor + dTerm_motor), -255, 255);
}


void CalculatePID()
{
OutputM1=updateMotor1Pid(target1,currentanalogue1);
OutputM2=updateMotor2Pid(target2,currentanalogue2);
}


void SetPower()
{
  //Motor 1
  if (abs(target1 - currentanalogue1) <= (DeadZone + FeedbackPotDeadZone1))
  {
    PowerM1 = 0;
  }
  else
  {
    PowerM1 = map(int(OutputM1),-255,255,-400,400);
  }
  
  //Motor 2
  if(abs(target2 - currentanalogue2) <= (DeadZone + FeedbackPotDeadZone2))
  {
    PowerM2 = 0;
  }
  else
  {
    PowerM2 = map(int(OutputM2),-255,255,-400,400);
  }


  md.setM1Speed(PowerM1);
  md.setM2Speed(PowerM2);
  
}


void loop()
{
//Program loop
while (1==1) //Important hack: Use this own real time loop code without arduino framework delays
{
FeedbackPotWorker();
SerialWorker();
CalculatePID();
if(disable==0)
{
SetPower();
}
}
}








après pour le câblage j'ai repris celui la sur la photo 





Oui sur axis Assignment il est par defaut 

j'avais essayé sans le end ca ne marché pas aussi je vient de le modifié 


merci 
_________________



Revenir en haut
Wanegain
Administrateur
Administrateur

Hors ligne

Inscrit le: 08 Mai 2012
Messages: 15 854
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: Belgique
Régions (France): Autre
Département (France): Autre
Ville: Bruxelles
17/04/1982 Masculin Bélier (21mar-19avr)
Point(s): 157 766
Moyenne de points: 9,95

MessagePosté le: Jeu 18 Oct - 10:03 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant

Avant de doubler les sorties du moteur, essaie un mode normal.

Ce qui est important pour le câblage c'est ça :
Pin map
_INA1 = 2;
_INB1 = 4;

Analog Pins
Pin 9 - pwm motor 1

Pin A0 - input of feedback positioning from motor 1

Quel type de potentiomètre tu as ?
_________________
Profils Converter et Codes Arduino
Tuto : simulateur pour moins de 450€
KIT pour créer son simulateur 2DOF


Revenir en haut
laurent34400
Occasionnel
Occasionnel

Hors ligne

Inscrit le: 08 Oct 2018
Messages: 27
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: France
Régions (France): Languedoc-Roussillon
Département (France): 34- Hérault
Ville: lunel
04/07/1985 Masculin
Point(s): 135
Moyenne de points: 5,00

MessagePosté le: Jeu 18 Oct - 10:20 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant

Du coup sur l arduino je laisse comme ca est sur la motomonster je doit laissé les quel numero?

Revenir en haut
laurent34400
Occasionnel
Occasionnel

Hors ligne

Inscrit le: 08 Oct 2018
Messages: 27
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: France
Régions (France): Languedoc-Roussillon
Département (France): 34- Hérault
Ville: lunel
04/07/1985 Masculin
Point(s): 135
Moyenne de points: 5,00

MessagePosté le: Jeu 18 Oct - 11:04 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant

je vient d essayé en branchant sur l arduino le 2/3/9  est sur la moto monster la 4/5/8 et le a1/b1  est rien j ai reverifié le com tout et ok 

Revenir en haut
Wanegain
Administrateur
Administrateur

Hors ligne

Inscrit le: 08 Mai 2012
Messages: 15 854
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: Belgique
Régions (France): Autre
Département (France): Autre
Ville: Bruxelles
17/04/1982 Masculin Bélier (21mar-19avr)
Point(s): 157 766
Moyenne de points: 9,95

MessagePosté le: Jeu 18 Oct - 11:11 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant

C'est pas 2 et 3 sur l'ARduino mais 2 et 4
Est-ce que le potentiomètre est bien connecté sur A0 ? C'est quel modèle de potentiomètre ?
_________________
Profils Converter et Codes Arduino
Tuto : simulateur pour moins de 450€
KIT pour créer son simulateur 2DOF


Revenir en haut
laurent34400
Occasionnel
Occasionnel

Hors ligne

Inscrit le: 08 Oct 2018
Messages: 27
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: France
Régions (France): Languedoc-Roussillon
Département (France): 34- Hérault
Ville: lunel
04/07/1985 Masculin
Point(s): 135
Moyenne de points: 5,00

MessagePosté le: Jeu 18 Oct - 11:21 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant

du coup 
la 9 de l arduino au 5 de la MM
la 4 de l arduino au 4 de la MM
la 2 de l arduino au 8 de la MM


c est bien ca ? 






Revenir en haut
Wanegain
Administrateur
Administrateur

Hors ligne

Inscrit le: 08 Mai 2012
Messages: 15 854
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: Belgique
Régions (France): Autre
Département (France): Autre
Ville: Bruxelles
17/04/1982 Masculin Bélier (21mar-19avr)
Point(s): 157 766
Moyenne de points: 9,95

MessagePosté le: Jeu 18 Oct - 11:34 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant

Je ne connais pas les pin à utiliser de la carte, il faut que je regarde dans la librairie utilisée du code
_________________
Profils Converter et Codes Arduino
Tuto : simulateur pour moins de 450€
KIT pour créer son simulateur 2DOF


Revenir en haut
laurent34400
Occasionnel
Occasionnel

Hors ligne

Inscrit le: 08 Oct 2018
Messages: 27
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: France
Régions (France): Languedoc-Roussillon
Département (France): 34- Hérault
Ville: lunel
04/07/1985 Masculin
Point(s): 135
Moyenne de points: 5,00

MessagePosté le: Jeu 18 Oct - 11:45 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant

Je les avait mis haut les code arduino 

Revenir en haut
Wanegain
Administrateur
Administrateur

Hors ligne

Inscrit le: 08 Mai 2012
Messages: 15 854
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: Belgique
Régions (France): Autre
Département (France): Autre
Ville: Bruxelles
17/04/1982 Masculin Bélier (21mar-19avr)
Point(s): 157 766
Moyenne de points: 9,95

MessagePosté le: Jeu 18 Oct - 11:55 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant

Si je comprends bien je pense que le 2 et le 4 doivent aller sur le 2 et le 4 de la MM
_________________
Profils Converter et Codes Arduino
Tuto : simulateur pour moins de 450€
KIT pour créer son simulateur 2DOF


Revenir en haut
laurent34400
Occasionnel
Occasionnel

Hors ligne

Inscrit le: 08 Oct 2018
Messages: 27
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: France
Régions (France): Languedoc-Roussillon
Département (France): 34- Hérault
Ville: lunel
04/07/1985 Masculin
Point(s): 135
Moyenne de points: 5,00

MessagePosté le: Jeu 18 Oct - 12:06 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant

je tombe sur ça sur internet je c est pas si c est bon 


que la je suis complètement perdu lol 






Revenir en haut
Wanegain
Administrateur
Administrateur

Hors ligne

Inscrit le: 08 Mai 2012
Messages: 15 854
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: Belgique
Régions (France): Autre
Département (France): Autre
Ville: Bruxelles
17/04/1982 Masculin Bélier (21mar-19avr)
Point(s): 157 766
Moyenne de points: 9,95

MessagePosté le: Jeu 18 Oct - 12:58 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant

Tu dois faire les connexions en fonction du code Arduino que tu as injecté !
Etant donné que c'est censé être un shield les pins doivent correspondre...
_________________
Profils Converter et Codes Arduino
Tuto : simulateur pour moins de 450€
KIT pour créer son simulateur 2DOF


Revenir en haut
laurent34400
Occasionnel
Occasionnel

Hors ligne

Inscrit le: 08 Oct 2018
Messages: 27
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: France
Régions (France): Languedoc-Roussillon
Département (France): 34- Hérault
Ville: lunel
04/07/1985 Masculin
Point(s): 135
Moyenne de points: 5,00

MessagePosté le: Jeu 18 Oct - 13:04 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant

c est quelqu un du forum qui me la fait passé par facebook je n'y connais rien 
 
si je comprend bien sur le code arduino je voit pour le moteur 1 
il faut câblé la 2 / 4 et 9 moteur 
si le potentiomètre est défectueux ça peut bloqué ou je peut par exemple le faire fonctionné sans .


a part game engine il y a rien a allumé en plus que la je sèche je voit pas pourquoi ça bloque .


Revenir en haut
Wanegain
Administrateur
Administrateur

Hors ligne

Inscrit le: 08 Mai 2012
Messages: 15 854
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: Belgique
Régions (France): Autre
Département (France): Autre
Ville: Bruxelles
17/04/1982 Masculin Bélier (21mar-19avr)
Point(s): 157 766
Moyenne de points: 9,95

MessagePosté le: Jeu 18 Oct - 13:13 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant

Le potentiomètre est indispensable...
Pour les tests uniquement game engine est nécessaire
_________________
Profils Converter et Codes Arduino
Tuto : simulateur pour moins de 450€
KIT pour créer son simulateur 2DOF


Revenir en haut
laurent34400
Occasionnel
Occasionnel

Hors ligne

Inscrit le: 08 Oct 2018
Messages: 27
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: France
Régions (France): Languedoc-Roussillon
Département (France): 34- Hérault
Ville: lunel
04/07/1985 Masculin
Point(s): 135
Moyenne de points: 5,00

MessagePosté le: Jeu 18 Oct - 13:16 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant

j ai essayer avec un autre potentiomètre mais rien j ai refait les câblage 
2A ---- 2 MM
4A -----4 MM
9A -----9 MM 


le 5v et au potentiomètre mais y a rien 


Revenir en haut
Wanegain
Administrateur
Administrateur

Hors ligne

Inscrit le: 08 Mai 2012
Messages: 15 854
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: Belgique
Régions (France): Autre
Département (France): Autre
Ville: Bruxelles
17/04/1982 Masculin Bélier (21mar-19avr)
Point(s): 157 766
Moyenne de points: 9,95

MessagePosté le: Jeu 18 Oct - 13:27 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant

5v et la masse je suppose au potentiomètre ?
_________________
Profils Converter et Codes Arduino
Tuto : simulateur pour moins de 450€
KIT pour créer son simulateur 2DOF


Revenir en haut
laurent34400
Occasionnel
Occasionnel

Hors ligne

Inscrit le: 08 Oct 2018
Messages: 27
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: France
Régions (France): Languedoc-Roussillon
Département (France): 34- Hérault
Ville: lunel
04/07/1985 Masculin
Point(s): 135
Moyenne de points: 5,00

MessagePosté le: Jeu 18 Oct - 13:28 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant

oui

Revenir en haut
Wanegain
Administrateur
Administrateur

Hors ligne

Inscrit le: 08 Mai 2012
Messages: 15 854
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: Belgique
Régions (France): Autre
Département (France): Autre
Ville: Bruxelles
17/04/1982 Masculin Bélier (21mar-19avr)
Point(s): 157 766
Moyenne de points: 9,95

MessagePosté le: Jeu 18 Oct - 14:34 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant

Pour faire tes tests tu vas bien dans Output testing et tu démarres le test ?
_________________
Profils Converter et Codes Arduino
Tuto : simulateur pour moins de 450€
KIT pour créer son simulateur 2DOF


Revenir en haut
laurent34400
Occasionnel
Occasionnel

Hors ligne

Inscrit le: 08 Oct 2018
Messages: 27
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: France
Régions (France): Languedoc-Roussillon
Département (France): 34- Hérault
Ville: lunel
04/07/1985 Masculin
Point(s): 135
Moyenne de points: 5,00

MessagePosté le: Jeu 18 Oct - 14:45 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant

voici la ou je vais pour faire les essaie 






Revenir en haut
laurent34400
Occasionnel
Occasionnel

Hors ligne

Inscrit le: 08 Oct 2018
Messages: 27
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: France
Régions (France): Languedoc-Roussillon
Département (France): 34- Hérault
Ville: lunel
04/07/1985 Masculin
Point(s): 135
Moyenne de points: 5,00

MessagePosté le: Jeu 18 Oct - 14:46 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant



Revenir en haut
Wanegain
Administrateur
Administrateur

Hors ligne

Inscrit le: 08 Mai 2012
Messages: 15 854
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: Belgique
Régions (France): Autre
Département (France): Autre
Ville: Bruxelles
17/04/1982 Masculin Bélier (21mar-19avr)
Point(s): 157 766
Moyenne de points: 9,95

MessagePosté le: Jeu 18 Oct - 15:07 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant

Et quand tu fais Turn On, il ne se passe rien ?

Est-ce que tu as complété le profil par défaut dans Axis Assignment ?
_________________
Profils Converter et Codes Arduino
Tuto : simulateur pour moins de 450€
KIT pour créer son simulateur 2DOF


Revenir en haut
laurent34400
Occasionnel
Occasionnel

Hors ligne

Inscrit le: 08 Oct 2018
Messages: 27
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: France
Régions (France): Languedoc-Roussillon
Département (France): 34- Hérault
Ville: lunel
04/07/1985 Masculin
Point(s): 135
Moyenne de points: 5,00

MessagePosté le: Jeu 18 Oct - 15:16 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant

non il ce passe rien 







Je suis vraiment désolé de te dérangé mais la je suis out complet 


Revenir en haut
laurent34400
Occasionnel
Occasionnel

Hors ligne

Inscrit le: 08 Oct 2018
Messages: 27
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: France
Régions (France): Languedoc-Roussillon
Département (France): 34- Hérault
Ville: lunel
04/07/1985 Masculin
Point(s): 135
Moyenne de points: 5,00

MessagePosté le: Jeu 18 Oct - 15:18 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant

je suis tombé sur ça mais je vois pas comment câblé l arduino  .


je suis vraiment désolé de te dérangé avec tout ca 







Revenir en haut
Wanegain
Administrateur
Administrateur

Hors ligne

Inscrit le: 08 Mai 2012
Messages: 15 854
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: Belgique
Régions (France): Autre
Département (France): Autre
Ville: Bruxelles
17/04/1982 Masculin Bélier (21mar-19avr)
Point(s): 157 766
Moyenne de points: 9,95

MessagePosté le: Jeu 18 Oct - 16:04 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant

Si tu as le code qui va avec alors suit ce câblage...
_________________
Profils Converter et Codes Arduino
Tuto : simulateur pour moins de 450€
KIT pour créer son simulateur 2DOF


Revenir en haut
laurent34400
Occasionnel
Occasionnel

Hors ligne

Inscrit le: 08 Oct 2018
Messages: 27
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: France
Régions (France): Languedoc-Roussillon
Département (France): 34- Hérault
Ville: lunel
04/07/1985 Masculin
Point(s): 135
Moyenne de points: 5,00

MessagePosté le: Jeu 18 Oct - 16:10 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant

le truc c est que je ne connais pas a quoi servent les connectique sur l arduino y a du voltage partout mais rien ne bouge


sur l arduino j ai ca 




 1.24 = improve function with the power command
  
  10 bits (16 bits value / 64)
  
  Com Speed : 115200 bauds
  
  XL<Axis1a>CXR<Axis2a>C
  XE00C - End


  Pin map
  _INA1 = 2;
  _INB1 = 4;
  _EN1DIAG1 = 6; (inutile)


  _INA2 = 7;
  _INB2 = 8;
  _EN2DIAG2 = 12; (inutile)




Analog Pins
  Pin 9  - pwm motor 1
  Pin 10 - pwm motor 2


Pin A0 - input of feedback positioning from motor 1
Pin A1 - input of feedback positioning from motor 2
  
As well 5v and GND pins tapped in to feed feedback pots too.
*/


Revenir en haut
Wanegain
Administrateur
Administrateur

Hors ligne

Inscrit le: 08 Mai 2012
Messages: 15 854
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: Belgique
Régions (France): Autre
Département (France): Autre
Ville: Bruxelles
17/04/1982 Masculin Bélier (21mar-19avr)
Point(s): 157 766
Moyenne de points: 9,95

MessagePosté le: Jeu 18 Oct - 16:18 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant

Change la vitesse de communication dans Interface settings de 9600 à 115200
_________________
Profils Converter et Codes Arduino
Tuto : simulateur pour moins de 450€
KIT pour créer son simulateur 2DOF


Revenir en haut
laurent34400
Occasionnel
Occasionnel

Hors ligne

Inscrit le: 08 Oct 2018
Messages: 27
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: France
Régions (France): Languedoc-Roussillon
Département (France): 34- Hérault
Ville: lunel
04/07/1985 Masculin
Point(s): 135
Moyenne de points: 5,00

MessagePosté le: Jeu 18 Oct - 17:29 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant

j'ai essayé  rien ne fonctionne 

Revenir en haut
laurent34400
Occasionnel
Occasionnel

Hors ligne

Inscrit le: 08 Oct 2018
Messages: 27
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: France
Régions (France): Languedoc-Roussillon
Département (France): 34- Hérault
Ville: lunel
04/07/1985 Masculin
Point(s): 135
Moyenne de points: 5,00

MessagePosté le: Jeu 18 Oct - 19:41 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant

la j ai regardé partout je trouve rien j arrive pas a comprendre pourquoi rien ne démarre et je voit pas comment testé 


a moins d arrivé a trouvé un tuto avec les code arduino et motomonster 


Revenir en haut
Wanegain
Administrateur
Administrateur

Hors ligne

Inscrit le: 08 Mai 2012
Messages: 15 854
Dégagement de responsabilité: J'accepte
Lecture et respect de la charte: J'accepte
Pays: Belgique
Régions (France): Autre
Département (France): Autre
Ville: Bruxelles
17/04/1982 Masculin Bélier (21mar-19avr)
Point(s): 157 766
Moyenne de points: 9,95

MessagePosté le: Ven 19 Oct - 10:09 (2018)    Sujet du message: Aide mon moteur ne se lance pas Répondre en citant

Regarde du côté du tuto de RacingMat, il utilise une Moto Monster : https://www.racingfr.net/wbb/index.php?thread/665-diy-tuto-conception-d-un-…
_________________
Profils Converter et Codes Arduino
Tuto : simulateur pour moins de 450€
KIT pour créer son simulateur 2DOF


Revenir en haut
Contenu Sponsorisé






MessagePosté le: Aujourd’hui à 21:23 (2018)    Sujet du message: Aide mon moteur ne se lance pas

Revenir en haut
Montrer les messages depuis:   
Poster un nouveau sujet   Répondre au sujet    PCSHM (Playseats, cockpits et simulateurs home-made) Index du Forum -> Les tutoriels -> Questions Toutes les heures sont au format GMT + 2 Heures
Page 1 sur 1

 
Sauter vers:  

Index | creer un forum gratuit | Forum gratuit d’entraide | Annuaire des forums gratuits | Signaler une violation | Conditions générales d'utilisation
Powered by phpBB © 2001, 2018 phpBB Group
Traduction par : phpBB-fr.com powered by ArgenBLUE free template